[Wine] Unreal Media Server - no way to run in Linux

Dan Kegel dank at kegel.com
Sun May 4 11:33:58 CDT 2008

On Sun, May 4, 2008 at 3:19 AM, vladd <wineforum-user at winehq.org> wrote:
> I've just tried to run another application to test the server.
> The best candidate was UServerConfig.exe - a configurator for the server.
> So, when I run it, the following messages are displayed:
>  $ wine UServerConfig.exe
> fixme:ole:CoInitializeSecurity (0x671198,-1,(nil),(nil),4,3,(nil),0,(nil)) - stub!
>  err:ole:CoGetClassObject class {88d969c1-f192-11d4-a65f-0040963251e5} not registered

It seems to want msxml3 or msxml4.  Try
  wget http://kegel.com/wine
  sh winetricks msxml3

>  fixme:quartz:NullRendererInner_QueryInterface No interface for {37d84f60-42cb-11ce-8135-00aa004bb851}!

That's interesting.  Looks like we need to implement the
IPersistPropertyBag for the null renderer in Quartz?

>  As I suppose, UMediaServer gets started - wineserver starts to
> listen on its tcp port 5119.

Heck, you don't have to start UServerConfig for that; starting Notepad
or even cmd will start the service and start listening on port 5119.

> I was even able to connect to that
> port, it connects but drops the connection in a few seconds.
> The following message is displayed in wine session:
>  fixme:dbghelp:SymGetModuleInfo Wrong size

I reproduced this by installing unreal media server, starting notepad,
then doing
  mplayer mms://localhost:5119/mediaroot/test.avi
as suggested by http://www.umediaserver.net/umediaserver/faq.html

But you don't even need mplayer; you can even just do
  telnet localhost 5119
to trigger that "Wrong size" message.

dbghelp usually means there's been a crash.
To find out more, we usually try getting a log with WINEDEBUG=+relay,+seh
or running in winedbg.  In this case, the log just says the crash
happens very soon after the socket is accepted,
and I can't figure out how to use winedbg on a service.

I've filed a bug report with this info, see
- Dan

More information about the wine-users mailing list