[Wine] Re: Guild Wars Won't Even Get to Login Screen

Aaron wineforum-user at winehq.org
Sun May 11 20:21:11 CDT 2008

vitamin wrote:
> gnivler wrote:
> > I think you know more about what you're doing than I do, but I'll give it a shot.
> > 
> > 
> > > [aaron at MyRoom ~]$ wine explorer /desktop=name,800x600 "C:\Program Files\Guild Wars\Gw.exe" -windowed -noshaders -nosound 
> > 
> > 
> > The -no switches are new to me (alot is), they are wine switches?
> No Wine does not have any options except of "--version". These are application specific options I guess.
> Also note that the "explorer.." part - that is to run in virtual desktop. Have you tried that?

Yes, sorry if I misspoke.  The -noshaders -windowed triggers are specific to Guild Wars, they're supposed to help out with getting the graphics to load.  I've tried both with and without them, as well as forcing DX8.

I'm not sure what your last question is asking, I have tried it both with the "explorer" option, and without.  I use the "explorer" option to prevent Wine from freezing X on me.

GW currently starts, and proceeds to download files from ArenaNet, but once the actually game screen attempts to load, I get the GW cursor but no login screen, and it freezes me out of X, though I can still see my desktop.

err:d3d:WineD3D_ChoosePixelFormat Can't find a suitable iPixelFormat
fixme:d3d:IWineD3DDeviceImpl_SetDialogBoxMode (0x13abf8) Dialogs cannot be disabled yet
err:d3d:getColorBits Unsupported format: WINED3DFMT_R32F
fixme:d3d:IWineD3DResourceImpl_SetPriority (0x2ba01d0) : stub
fixme:d3d:IWineD3DResourceImpl_SetPriority (0x2ba06c8) : stub
fixme:d3d:IWineD3DResourceImpl_SetPriority (0x2891a40) : stub
err:seh:raise_exception Exception frame is not in stack limits => unable to dispatch exception.

It used to give me a "Guild Wars has encountered an Unrecoverable Graphics Error..." dialog menu within Wine, but it does not anymore.

More information about the wine-users mailing list