[Wine] Halo2 and msvc issues

haarp wineforum-user at winehq.org
Sun May 18 13:42:56 CDT 2008

Since Halo 2 still doesn't seem to work in Wine, or at least noone put an entry saying it worked up in AppDB, I decided to give it another shot using 1.0-rc1.

I have no hope that the original version (which is Vista-only) will ever EVER work in Wine, so I got me the dopeman XP version. This is cracked or something to work with XP.
This version does not use an installer, but instead comes with a pre-installed game dir and asks you to execute 2 supplied msi files. These are vcredist.msi and
Xlive manages to install flawlessly with msiexec /i. vcredist however fails. Or at least, that is what I make from the console output. Maybe it actually installed, I am unsure.

err:msi:ITERATE_PublishAssembly Component not set for install, not publishing assembly

An attempt to extract the supplied vcredis1.cab gives me a file named FL_msdia71_dll_2_____X86.3643236F_FC70_11D3_A536_0090278A1BB8. Ugh. This file isn't even executable, it's a lib. Let's just skip this msi for now.

Ok, continuing, I tried to execute the Loader.exe with halo2.exe as an argument (like in the original bat file). This fails miserably.

err:module:import_dll Library MSVCR80.dll (which is needed by L"C:\\windows\\system32\\xlive.dll") not found
err:module:import_dll Library MSVCP80.dll (which is needed by L"C:\\windows\\system32\\xlive.dll") not found

Tough luck. Omitting the Loader.exe and directly executing halo2.exe results in the same behavior. These are 2 DLLs that I can't just put into system32, since they aren't supposed to be loaded like this. Attempts to do this resulted in 
> an application has made an attempt to load the c runtime library incorrectly

Of course. So the proper way is to use winetricks to install vcrun2005 and vcrun2005sp1. This should work well to provide the proper libs in windows/winsxs. Which it did.
However, attempts to launch the game still fail. It still says that it can't find aforementioned msvc8*.dll, although they are present in winsxs.

That's where I am stuck now. Does anyone have an idea what to do next?
I had a bug for this filed, but Austin slapped my hand for not installing the game properly and closed the report ;) Well, last time I checked, it wouldn't install at all in Wine.
If I get this to work I wouldn't have any problems becoming an AppDB maintainer for it, since I'm already maintaining other games.

More information about the wine-users mailing list