[Wine] Re: CorelDraw X3

hasi wineforum-user at winehq.org
Wed May 21 15:04:16 CDT 2008

It's amazing that we are now going towards full functionality of Corel X3 on wine! This is awesome!

Anyway, I haven't been completely successful yet. This is what I did, using wineRC1 on Hardy (32bit): 

rm -r .wine
wine Setup.exe 

The installer gets almost done with everything, hangs at the message "Publishing Product Information". I should say that this is the regular version of Corel X3 (I am not sure what the "portable version" is). 
When I kill the installer, it seems that all necessary files are on disk. When I do 
wine CorelDRW.exe

, I get the error: "The UI Language Registration is invalid". 
After clicking OK, I get a runtime error ("abnormal program termination"). The terminal has only two lines: 

fixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot
fixme:toolhelp:Heap32ListFirst : stub

When I do the installation again in a clean .wine, go to the detailed installation options and unselect everything that's not absolutely necessary (i.e. installing only the CorelDRW program), I can actually get the installer to finish. Still, there are many messages in the terminal. There are tons of stubs. A more important one at the end seems to be: 

fixme:advapi:LookupAccountNameW (null) L"hasi" (nil) 0x7e2e0088 (nil) 0x7e2e008c 0x7e2e0080 - stub
fixme:advapi:LookupAccountNameW (null) L"hasi" 0xa5e9c0 0x7e2e0088 0xa5e6b0 0x7e2e008c 0x7e2e0080 - stub
fixme:msi:ACTION_HandleStandardAction unhandled standard action L"SetODBCFolders"
fixme:msi:msi_unimplemented_action_stub MigrateFeatureStates -> 34 ignored L"Upgrade" table values
err:seh:setup_exception_record stack overflow 1140 bytes in thread 0042 eip b7c961e3 esp 7e1d2ebc stack 0x7e1d2000-0x7e1d3000-0x7e2e3000
fixme:advapi:LookupAccountNameW (null) L"hasi" (nil) 0x7deafe0c (nil) 0x7deafe10 0x7deafe04 - stub
fixme:advapi:LookupAccountNameW (null) L"hasi" 0xf82848 0x7deafe0c 0xf810e0 0x7deafe10 0x7deafe04 - stub
fixme:msi:ACTION_HandleStandardAction unhandled standard action L"SetODBCFolders"

Is there any fix to this? Is it because I am not using the "portable" version? 
Insalling native MSXML4 did not help. 
Any help is appreciated. 

More information about the wine-users mailing list