[Wine] Selecting from 2 sound devices -??

NixNoob wineforum-user at winehq.org
Tue May 27 11:20:06 CDT 2008

Background Info:

OS ver: Ubuntu 8.04 desktop (Hardy)
WINE ver: 0.9.59
Sound device #1: Onboard SiS (661FX chipset) Realtek AC'97
Sound device #2: Yamaha DS-1 PCI

Problem Description:

No matter what combination of settings I use in System > Preferences > Sound  and  Applications > WINE > Configure WINE > Audio Tab  I seem to use, I cannot seem to force WINE to use only the Yamaha DS-1 PCI card... I know this must be possible, because it DID briefly use the correct device... Once. And I may have had the other device in use at the time...

At the present moment, WINE insists on sending ALL sound to the onboard SiS Realtek chip, (EVEN when System > Preferences > Sound  is set to ONLY use the Yamaha card) which rather defeats the entire purpose of my having installed WINE. (For use with WinAmp)

Basically, I would like to have WinAmp under WINE sending all audio to the Yamaha card, and all other sounds directed through the onboard. Everything else is going roughly where I want it, directed by the settings from System > Preferences > Sound.

I have also tried all possible DirectSound and WaveOut options in WinAmp to force the output to the correct device, to no avail.

As my moniker suggests, I'm very new to Linux, but not to computers in general. Having just switched to 'nix after Vista's SP1 detected my bootloader hack, the recurring theme I seem to have is hardware issues. 

Having (eventually) managed to get my Nvidia GeForce4 440MX SE 8x AGP video card to work correctly, (After finding some brief tutorials and working out the important parts of the /etc/X11/xorg.conf to modify) I'm sure this problem is surmountable also... I just don't know enough as yet to crack it on my own, so any help would be greatly appreciated.

I hope the above info is sufficient in helping work this one out.


More information about the wine-users mailing list