[Wine] Re: application wont work properly

vitamin wineforum-user at winehq.org
Fri May 30 18:09:34 CDT 2008

delta9 wrote:
> Im using an application called saturn for my university assignement.
> The problem is that it fails to fully operate under linux with wine.
> If im not mistaken the application works like this:
> Satwin is the windows front end that calles *.bat files that are part of the suit saturn.
> While wine loads the satwin front end perfectly it fails to execute the *.bat files that are part of the saturn suit.
> Lets have an example.There is a program called M1 in the suit.To run M1 i just have to click the icon M1 at the satwin front end and i then choose the file to use.
> Alternatevely using dos or a command line at windows i can do the same thing without the satwin front end by typing: M1.bat name_of_file.dat
> I have also noticed that when i use satwin front end at windowz and when i run eg M1 a black dos prompt window pops and the M1 application is working(obviously the pop up command prompt window executes the command M1.bat name_of_file.dat)
> Wine fails to do that part and as a result non of the programs is running.
> Any ideas to fix this?
> Thanks a lot in advance

Try running that with Wine's 'cmd' and not directly with "wine". However keep in mind that some functionality is still not supported in batch files.

More information about the wine-users mailing list