[Wine] Re: Cannot install Visual C++ version 6.0 (VC6)

resander wineforum-user at winehq.org
Mon Nov 10 07:02:17 CST 2008

I ran sh winetricks vcrun6, but it did not make any change. The VC6 install failed like before.

I am in the process of moving away from Windows and am not yet comfortable with the Ubuntu commandline, apt package installers etc, so here is what I did:

ken at ken-desktop:~$ sh winetricks vcrun6
Executing wine /home/ken/.winetrickscache/vc6redistsetup_enu.exe /T:C:\winetrickstmp /c
Executing cabextract /home/ken/.winetrickscache/vcredist.exe
Extracting cabinet: /home/ken/.winetrickscache/vcredist.exe
  extracting VCRedist.inf
  extracting PreSetup.exe
  extracting W95INF32.DLL
  extracting W95INF16.DLL

After that tried to install VC6 from command line by:

ken at ken-desktop:~/Desktop/VC6$ wine setup.exe
wine: Unhandled page fault on read access to 0x00000000 at address 0x411799 (thread 0009), starting debugger...
Unhandled exception: page fault on read access to 0x00000000 in 32-bit code (0x00411799).

I also used the Ubuntu GUI File Browser by right-clicking the VC6 setup.exe file and selecting 'Open from Wine' from the popup menu, but Wine exited without giving any error message when I clicked the 'Next' button in the VC6 installer.

winetrics extracted run-time dlls, but I could not find them by 'Search for Files' on the Ubuntu 'Places' menu (wanted to try 'file search' from the command line too, but didn't know what to type). I tried winetricks a second time, but was told that vcrun6 had already been installed.

Still hoping to install, but how to?

More information about the wine-users mailing list