[Wine] Re: Cannot install Visual C++ version 6.0 (VC6)

resander wineforum-user at winehq.org
Tue Nov 11 07:37:00 CST 2008

It works!

The remedy is to choose Windows 98 for Windows versions for Default Settings in the Applications tab of WineConfig.

Before realizing this I had uninstalled Wine 1.1.8 and put 1.0.1 back. After sh winetricks vcrun6 dcom98 the VC6 install was still failing as before.

I think the VC6 install will probably work for all versions after Wine 1.0.1 when Win98 is selected. Also, dcom98 may only be needed if you use Microsoft's COM technology (my guess).

Does VC6 work? Maybe - so far it looks good. I compiled files from a project already ported from Windows to Ubuntu and used the project source files in situ on Ubuntu without change. The project contains 35 files and only 3 failed to compile because I had already converted these to platform-dependent Linux code. Hopefully, it will run too when I convert these back to Windows code.

I will report how I installed and the outcome of the port(s) (there are more apps to get across to Linux) in the applications database for VC6.

More information about the wine-users mailing list