[Wine] Lego Star Wars and Spore are running slow suddenly.

theShaggy wineforum-user at winehq.org
Sun Nov 16 22:03:40 CST 2008

I upgraded to Ubuntu Intrepid Ibex, and Wine 1.1.8 some time last week, and then reinstalled Spore to give it some play.  It worked fine for a couple of days, but now I'm in the space stage and the game is incredibly sluggish.

This wasn't happening beforehand, it was running fast and marvellously smooth until I tried to stop a war on my home planet.  This appears to be a recurring theme, and I think it has something to do with the graphics.  It doesn't seem to fix in safe mode or with Compiz disabled, and it isn't just confined to Spore.  Lego Star Wars II is also running incredibly slowly when before it was running fine.

I have a Nvidia 7300GS with the almost-latest driver (177.80), and I'm running both with OSS sound and padsp to avoid PulseAudio conflicts.  As I say, this only started after I upgraded both my OS and my Wine version, but plenty of time afterwards that I still used both with minimal problem.

Any ideas?  Where can I look for ideas on what is going on?  It appears to be a graphics problem, as none of the planets load in Spore until I'm trying to land on them, and LSWII just slows to a crawl.  Music and sound is still fine, though.


More information about the wine-users mailing list