[Wine] Wine - WoTLK opengl Problem.

Reix wineforum-user at winehq.org
Mon Nov 17 19:40:01 CST 2008


This is my first post here.

I've started with linux some months ago, but i still keep my dual boot to play games. I was able to run work windows soft on Wine, but wasn't able to run wow.

I want to run it on linux so i canget rid of Dual boot but i'm having some problems to run it correctly.

I've managed to run the game perfecly with "d3d" but the FPS is very low. Even with pixal shader option unmarked on Wine its unplayable, if i mark pixal shader when i log in the game the screen stays all black. I 

When i run it on opengl it runs smoothly fast, but i have a problem with lightnings on screen an all text become unreadable (see pics):


(It doesn't matter if it is windowed or not).

I have an Mobile HD2400 from ATI with 128 MB DDR3.

I've tried to make changes on Config.wtf :

SET locale "enUS"
SET portal "us"
SET realmList "us.logon.worldofwarcraft.com"
SET patchlist "us.version.worldofwarcraft.com"
SET coresDetected "1"
SET hwDetect "0"
SET gxApi "opengl"
SET gxColorBits "24"
SET gxDepthBits "24"
SET gxResolution "1280x800"
SET ffxDeath "0"
SET ffxGlow "0"
SET ffxSpecial "0"
SET M2UseShaders "0"
SET gxRefresh "60"
SET gxMultisampleQuality "0.000000"
SET gxFixLag "0"
SET videoOptionsVersion "1"
SET movie "0"
SET Gamma "1.000000"
SET showToolsUI "1"
SET Sound_OutputDriverName "System Default"
SET Sound_MusicVolume "0.40000000596046"
SET Sound_AmbienceVolume "0.60000002384186"
SET farclip "287"
SET particleDensity "1.000000"
SET checkAddonVersion "0"
SET mouseSpeed "0.5"
SET readTOS "1"
SET readEULA "1"
SET Sound_VoiceChatInputDriverName "System Default"
SET Sound_VoiceChatOutputDriverName "System Default"
SET ChatMusicVolume "0.29999998211861"
SET ChatSoundVolume "0.39999997615814"
SET ChatAmbienceVolume "0.29999998211861"
SET realmName "Uldaman"
SET gameTip "10"
SET VoiceActivationSensitivity "0.39999997615814"
SET gxWindow "1"
SET gxVSync "0"
SET textureFilteringMode "0"
SET baseMip "1"
SET spellEffectLevel "0"
SET environmentDetail "0.5"
SET weatherDensity "0"
SET M2UsePixelShaders "0"
SET pixelShaders "0"

I've tried to add some lines on xorg.conf:


Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"abnt2"
	Option		"XkbLayout"	"br"

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"

Section "InputDevice"
	Identifier	"Synaptics Touchpad"
	Driver		"synaptics"
	Option		"SendCoreEvents"	"true"
	Option		"Device"	"/dev/psaux"
	Option		"Protocol"	"auto-dev"
	Option		"HorizEdgeScroll"	"0"

Section "Device"
	Identifier	"Configured Video Device"
	Driver		"fglrx"
	Option "Capabilities" "0x00000800"
	Option "UseFastTLS" "off"
	Option "KernelModuleParm" "locked-userpages=0"

Section "Monitor"
	Identifier	"Configured Monitor"

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
	Device		"Configured Video Device"
	Defaultdepth	24

Section "ServerLayout"
	Identifier	"Default Layout"
  screen "Default Screen"
	Inputdevice	"Synaptics Touchpad"
Section "Module"
	Load		"glx"

I've added the OpenGL key with regedit

But none of this stuff seems to work.

Does anyone have any other tips on what i can look for to solve this problem? I've googled for about 5 hours and nothing else seemed reasonable.

i'd thank in advance to anyone that help me...

More information about the wine-users mailing list