[Wine] Re: Problems compiling git under OS X

fuori wineforum-user at winehq.org
Fri Nov 21 10:38:07 CST 2008

Using fink did not make any difference (of course not... Well worth a shot, anyway), so I switched back to MacPorts as I'm used to it by now.
I triple-checked the paths in DYLD_LIBRARY_PATH and still, ./configure does not recognize the installed libraries.
I then tried 1.1.8 with the animated cursor patch, as really my only goal is to get RA3 to work. ./configure does still complain about not finding the aforesaid libraries, and make quits with a new error:

../tools/sfnt2fnt -o coue1255.fon -d 128 ./courier.ttf 13,1255,8
dyld: Symbol not found: __cg_jpeg_resync_to_restart
  Referenced from: /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/ImageIO
  Expected in: /port/lib/libJPEG.dylib

I tried installing wine-devel (which is 1.1.8) using MacPorts, too and it seems to compile just fine, except winecfg won't start due to the following errors:

noname:wine-1.1.8 fridbert$ winecfg
err:module:load_builtin_dll failed to load .so lib for builtin L"gdi32.dll": dlopen(/port/lib/wine/gdi32.dll.so, 258): Symbol not found: __cg_jpeg_resync_to_restart
  Referenced from: /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/ImageIO
  Expected in: /port/lib/libJPEG
err:module:import_dll Loading library gdi32.dll (which is needed by L"C:\\windows\\system32\\user32.dll") failed (error c000007a).
err:module:import_dll Library user32.dll (which is needed by L"C:\\windows\\system32\\shlwapi.dll") not found

After printing this, it just hangs.

Any clues..? [/code]

More information about the wine-users mailing list