[Wine] Re: Apps slow down after several minutes

faceplant wineforum-user at winehq.org
Sat Nov 29 21:13:12 CST 2008

I disabled desktop effects and there was no difference. I ran "pusleaudio --kill" which I assume disabled PulseAudio ("pactl stat" output "Connection failure: Connection refused" after doing so. Before it showed a bunch of info), but there was still no change.

The typical command line output I get is

ALSA lib pcm.c:2144:(snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
ALSA lib pcm.c:2144:(snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
ALSA lib pcm.c:2144:(snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
err:alsa:ALSA_CheckSetVolume Could not find 'PCM Playback Volume' element
fixme:mixer:ALSA_MixerInit No master control found on Brooktree Bt878, disabling mixer
fixme:d3d:IWineD3DImpl_FillGLCaps OpenGL implementation supports 32 vertex samplers and 32 total samplers
fixme:d3d:IWineD3DImpl_FillGLCaps Expected vertex samplers + MAX_TEXTURES(=8) > combined_samplers
fixme:win:EnumDisplayDevicesW ((null),0,0x32ef54,0x00000000), stub!
err:wgl:internal_SetPixelFormat Invalid operation on root_window
err:d3d:CreateContext SetPixelFormat failed on HDC=0x370 for iPixelFormat=3
err:d3d:IWineD3DDeviceImpl_CreateSwapChain Failed to create a new context
fixme:d3d:IWineD3DDeviceImpl_CreateSwapChain (0x144378) Something's still holding the front buffer
fixme:d3d9:IDirect3DDevice9Impl_CreateAdditionalSwapChain (0x13ffc0) call to IWineD3DDevice_CreateSwapChain failed
fixme:d3d9:IDirect3D9Impl_CreateDevice (0x13f560) D3D Initialization failed for WineD3DDevice 0x144378
fixme:d3d:IWineD3DDeviceImpl_SetSoftwareVertexProcessing (0x15c078) : stub
fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x5e42f98,0x5d97960): stub
fixme:d3d_surface:IWineD3DSurfaceImpl_BindTexture >>>>>>>>>>>>>>>>> GL_INVALID_ENUM (0x500) from glBindTexture @ surface.c / 2382
fixme:d3d_surface:IWineD3DSurfaceImpl_BindTexture >>>>>>>>>>>>>>>>> GL_INVALID_ENUM (0x500) from glTexParameteri(dimension, GL_TEXTURE_WRAP_S, GL_CLAMP_TO_EDGE) @ surface.c / 2384
fixme:d3d_surface:IWineD3DSurfaceImpl_BindTexture >>>>>>>>>>>>>>>>> GL_INVALID_ENUM (0x500) from glTexParameteri(dimension, GL_TEXTURE_WRAP_T, GL_CLAMP_TO_EDGE) @ surface.c / 2386
fixme:d3d_surface:IWineD3DSurfaceImpl_BindTexture >>>>>>>>>>>>>>>>> GL_INVALID_ENUM (0x500) from glTexParameteri(dimension, GL_TEXTURE_WRAP_R, GL_CLAMP_TO_EDGE) @ surface.c / 2388
fixme:d3d_surface:IWineD3DSurfaceImpl_BindTexture >>>>>>>>>>>>>>>>> GL_INVALID_ENUM (0x500) from glTexParameteri(dimension, GL_TEXTURE_MIN_FILTER, GL_NEAREST) @ surface.c / 2390
fixme:d3d_surface:IWineD3DSurfaceImpl_BindTexture >>>>>>>>>>>>>>>>> GL_INVALID_ENUM (0x500) from glTexParameteri(dimension, GL_TEXTURE_MAG_FILTER, GL_NEAREST) @ surface.c / 2392
fixme:d3d_surface:IWineD3DSurfaceImpl_BindTexture >>>>>>>>>>>>>>>>> GL_INVALID_ENUM (0x500) from glBindTexture @ surface.c / 2401
fixme:d3d_surface:surface_allocate_surface >>>>>>>>>>>>>>>>> GL_INVALID_ENUM (0x500) from glTexImage2D @ surface.c / 404
fixme:d3d_surface:read_from_framebuffer_texture >>>>>>>>>>>>>>>>> GL_INVALID_ENUM (0x500) from glCopyTexSubImage2D @ surface.c / 968
fixme:dinput:SysMouseAImpl_Acquire Clipping cursor to (0,0)-(1024,768)

though the slowdown doesn't seem to correlate with any command line output. For example, once the slowdown occurred before getting to the 
fixme:dinput:SysMouseAImpl_Acquire Clipping cursor to (0,0)-(1024,768)

 line. I closed the program and ran it again and it printed that line, but was still running smoothly.

I should point out that despite the 
ALSA lib pcm.c:2144:(snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so

 messages, the sound is fine.

I'm running Fedora 9 64-bit and Wine 1.1.9.

More information about the wine-users mailing list