[Wine] application doesnt start at startup when run via WINE !

noble_curious wineforum-user at winehq.org
Mon Oct 6 04:13:56 CDT 2008

[Evil or Very Mad] 
Hi all,

I am using Fedora 8 Linux.

I have a situation where i need to start a service at startup. the service is started using wine say... ` wine MyService.exe` 
I made a small daemon script for it which has start and stop functions where start function just runs above statement. Then I have configured this script to start at runlevel 5. Now the situation is that at startup there is no sign of my service being started. To verify if the service script is OK.. I run this script at shell 
        service MyService start
where MyService is  the script under init.d directory. But nothing happened
But strage thing is that when I run script like this:
        /etc/init.d/MyService start
       /etc/rc.d/init.d/MyService start
That works and my service is started!

I was suspicious if there is something wrong with my MyService.exe application so I changed the MyService script start function as
                     wine notepad &
and the same thing happened!. While running service using service command it doesnt starts notepad while if I provide full path of the service script it then started notepad. What is the problem here. I then creaated another small application as native Linux which was small server started to accept clients. This application was successfully started both with service command and by providing full path to the script. But when I compile same application program code in Windows and run it via WINE it doesnt start using service command. You people may check this at your system by testing if above listed start function runs successfully or not! using service command. I guess that while system boots and process through various runlevel it starts/stops services using service command and this is the reason it doesn't start at startup.
I tried to have one trick as well. I put another function with the name start2()

it was like this

             wine notepad &

             /etc/init.d/MyService start2
But this too was void. As it didnt work. Now one thing is obvious that there is problem due to wine here.

Please share your experience and help me out that how can I use wine to start windows application at startup. Kindly look into the matter


More information about the wine-users mailing list