[Wine] wine, 3D games and amd64

Darragh Bailey felix at compsoc.nuigalway.ie
Wed Apr 1 08:40:41 CDT 2009

On Wed, Apr 01, 2009 at 02:38:31PM +0200, Anigel wrote:
> Hi, and thanks for helping me :).
> In fact the resolution problem was corrected just after creating the
> pastebin. Sorry, I forgot to mention it.
> But the memory problem still remains... And I didn't find any relevant
> information about this. I'm thinking about installing a fresh 32-bits
> system, just to try if this helps ;).

Shouldn't make much of a difference in general, I have a 64bit gentoo
install at home and the only real problem I've had is with the ODBC and
that was specific to one application (BMW factory manual uses it for
indexing and subsequent searching). I suspect that similar issues may
impact some games requiring schannel due to the required 32bit libs not
being present either, but it hasn't stopped most games from playing. So
if you are getting the memory error with most games I suspect it's
something how wine was built on your system.

I would suggest trying by turning off any optimization cflags that you
are using by default.

use the file "/etc/portage/package.cflags" to just disable cflag
optimizations for wine only. Line format should be something like 
"app-emulation/wine CFLAGS"

I'll also post my use flags if I remember later :).

I have civilization I, II, III & IV lying around somewhere, although I
think there were problems with the installers with mine since they came
from the Chonicles set. But I'll try and see if either II or III work
now with the latest wine version sometime over the next 1-2 days, just
so you at least know if the general setup works or not.


"Nothing is foolproof to a sufficiently talented fool."

More information about the wine-users mailing list