[Wine] Re: Can't connect USB Serial (COM3)

zonyl wineforum-user at winehq.org
Fri Apr 3 14:57:18 CDT 2009

I have the a similar problem with a FTDI device (OBD II car scanner) on Ibext 8.10.  Everything worked fine with WINE on Feisty Fawn.

First of all the VAGCOM software (free download if someone wants to reproduce) sort of works in that it will open the port send / receive data on the first command.  However, after the first communication attempt, all subsequent operations in the program will fail (including the original working one).  Closing/Reloading the program in WINE will still fail even on the first command that originally worked and the port becomes useless to WINE for any program.

HOWEVER, if you unload / reload the usbserial module.  (rmmod usbserial, then unplug - replug the device) I can get it back to the same "First Command Works" scenario.  *Note: That reloading the ftdi doesnt solve the problem, only if you go further down the chain.

I would suspect at this point that it is not necessarily WINE that is causing this, but some regression problem in the Linux usbserial module in 8.10.

More information about the wine-users mailing list