[Wine] Resolution issue

danvari wineforum-user at winehq.org
Sat Apr 4 02:30:01 CDT 2009


i am using archlinux x86_64. i have got a 32bit chroot and also 32bit libs installed, so i can run 32bit apps inside the chroot or using the libs. now my problem:

my native desktop resolution is 1680x1050. i want to play my games in 800x600, 1024x768 or whatever. when i run a game in the chroot, it works like a charme, wine changes the resolution and i have no problems at all. when i run it using the 32bit libs wine changes the resolution, but i can move the mouse to the right or bottom corner and can so navigate to the whole desktop (as my desktop is bigger than the games resolution). it does happen to all tested games, half life (no source based), half life 2, morrowind, blair witch...
i tried different versions of the nvidia-drivers (nvidia-utils) and different versions of wine, latest is 1.1.18.
workaround: i change my desktop resolution to the games one in gnome for example, the run the game in wine. wine will not change the resolution anymore and i will not get this issue anymore (which makes first person shooter unplayable).
but: 32bit games, like ut2004 or doom3, are running fine via 32bit libs, there is no problem with the resolution.
i also tried changing wine's resolution method to xrandr, but then there is only one resolution (my desktop resolution) avaible in my games. playing in an emulated works therefore fine.
i asked in the archlinux forums, but nobody has this issue or could help me.

i know it worked two weeks ago, then i changed my distro to gentoo (where it also worked quite well) and then changed back to archlinux. do you maybe know how i can fix that or which lib is responsible for the resolution change?

More information about the wine-users mailing list