[Wine] Steam will not load after update

aaronm04 wineforum-user at winehq.org
Mon Apr 6 20:20:11 CDT 2009

I had Steam/TF2 working.  Using Suse 11.1 64-bit, Nvidia card/driver, 4Gb RAM, 2.6 Intel Quad CPU.  ALSA sound (pulse audio uninstalled), Windows Vista, full settings in winecfg.  My TF2 crashed and when I started Steam again, the Steam update downloaded and installed.  Then Steam wouldn't start any more.

I tried a new .wine dir.  Followed instructions for removing/reinstalling Steam.  Nada.  So I got patient and awaited some Wine updates.  I had wine 1.1.16 at the time and now even with 1.1.18, Steam will still not load.  Here is what I get:

aaron at destro:~> wine ~/.wine/drive_c/Program\ Files/Steam/Steam.exe
fixme:process:SetProcessShutdownParameters (00000100, 00000000): partial stub.
CellID: Fetching server list from CSDS. . .
fixme:urlmon:CoInternetSetFeatureEnabled 5, 0x00000002, 1, stub
fixme:urlmon:CoInternetSetFeatureEnabled 10, 0x00000002, 1, stub
CellID: CSDS returned 159 servers.
CellID: Connecting to . .
CellID: Connect to took 150 MS
CellID: Nothing beat our old best time of 16 MS
err:ntdll:RtlpWaitForCriticalSection section 0xc26fd4 "?" wait timed out in thread 0023, blocked by0024, retrying (60 sec)
Deleting active MRSW lock (0x115204), expect failure
aaron at destro:~>

I'm completely lost.  Anyone have any ideas.  I posted in the Steam forums in the AppDB and had a few who experienced similar problems.  Anyone know of a fix.  I searched and have come up empty.

Any help or a general direction as to the nature of the problem would be greatly appreciated.


More information about the wine-users mailing list