[Wine] Re: WoW toons loads 100% and just sits there

doumakes wineforum-user at winehq.org
Wed Dec 9 19:47:36 CST 2009

I have what might be a similar problem.  After the recent Launcher patch I was getting the permissions problem described in http://swiss.ubuntuforums.org/showthread.php?t=1321762 (http://swiss.ubuntuforums.org/showthread.php?t=1321762) and worked around it by skipping the Launcher.  I downloaded a big WoW upgrade yesterday.  Today I got the runtime error described in http://forum.winehq.org/viewtopic.php?t=7040 (http://forum.winehq.org/viewtopic.php?t=7040).  I worked around it like so:
wget http://www.kegel.com/wine/winetricks
sh winetricks vcrun2005sp1 vcrun2005

  Now, I am able to start WoW, log in, and enter the game world.

However, the game world behaves as if I'm experiencing a server disconnection.  I can move my toon, but my pet doesn't follow.  Other toons often are marked "Unknown."  NPCs don't interact, e.g., click on a flight master and nothing happens.  Logout and Exit Game buttons don't work.  This occurs with addons disabled.

$ wine --version
$ uname -a
Linux don-desktop 2.6.31-16-generic #53-Ubuntu SMP Tue Dec 8 04:02:15 UTC 2009 x86_64 GNU/Linux

Don't know whether to suspect wine, winetricks, or Blizzard.  Anyone else having similar behavior after the winetricks fix?

More information about the wine-users mailing list