[Wine] Having problems with wine mouse hack

thorin wineforum-user at winehq.org
Thu Feb 5 07:17:00 CST 2009

Hi. I've recently been trying to compile and use a custom version of wine with a mouse hack designed to fix bug 6971 to do with the mouse leaving the game window and leaving my character stuck in game, not being able to move or look around, etc. This problem specifically occurs in Swat 4 and Mass Effect.

The mouse hack is supposed to give me access to the registry key force_edge, in MouseWarpOverride. However, setting this option, or force or enable does absolutely nothing in either game. I've tried this with multiple wineprefixes to make sure that custom dlls are not the issue, but no luck so far. 

I've compiled, patched, and used wine-git to the best of my ability, to the best of my knowledge I'm doing it right. Does anyone have any ideas that would allow me to partially play these games, at least?

Also, the source code version of wine is sitting in a folder not in /usr/bin, but in another folder using a custom path command. It's worked fine for many different versions of wine so far.

Thanks in advance.

More information about the wine-users mailing list