[Wine] Updating to a Development Version breaks 'wine-dev'

linuxgamer000 wineforum-user at winehq.org
Thu Feb 5 13:12:36 CST 2009

Hi, I am relatively new to Linux but know what I'm doing.

I have installed Ubuntu and WinE (through synaptic package manager so it took the latest stable version, 1.0.1)

Warcraft III worked perfectly in this version. But GGClient (also known as Garena, a program used to play low-latency games with others on the internet through a VPN) does not work in this version of WinE. So I looked it up, and it has gold rating on 1.0.11, working perfectly.

So I install 1.0.11 from the repository of previous WinE versions on WineHQ site, and this successfully changes both wine and wine-dev versions, and Garena works! 

So what is the problem you ask? Well it says in Synaptic Package Manager that a package is now broken. I check it out, 'wine-dev' is considered broken by Synaptic because it has a dependency of the 'wine' version to be 1.0.1, although it itself is 1.0.11. If BOTH wine and wine-dev packages are 1.0.11, then why the hell does wine-dev have a dependency for the wine version to have to be 1.0.1?? It doesn't make sense, its the old dependency it had when it was 1.0.1.....

So I had to uninstall and downgrade back to 1.0.1 temporarily so i could install more stuff (cant install anything with a broken package)

Thanks in advance for your help.

More information about the wine-users mailing list