[Wine] Nox used to work fine but now it asks for a CD

noxx wineforum-user at winehq.org
Fri Feb 6 15:12:46 CST 2009

I'm using OpenSuSE 11.1 with wine version 1.1.9 downloaded from the repositories.

Nox is a game from Westwood that I used to play using wine until recently...
It required a CD to be played so I mounted it's image and linked it in to the dosdevices directory in ~/.wine. After doing that the game ran fine.

However, I was running out of space on my HOME partition so i used Gparted live CD to resize and move some partitions in order to get more space for my HOME partition. For some reason Gparted froze while copying my ROOT partition and so my OpenSUSE was ruined. So what I did was a clean install of the OS and told it to use the old HOME so all i had to do was install a few packages and the system would be good as new.

The problem is that now I just can't seem to get Nox to work because it allways says the CD is missing.
I've tried using diferent letters for the links to the mounted ISO, I've also tried using winecfg autodetect and even tried reinstalling wine and deleting ~/.wine

Can some one please help me out?

Here's the output from the terminal after running Nox and quiting it:

noxx at linux-3ynw:/windows/D/games/Nox> wine NOX.EXE
fixme:d3d:IWineD3DImpl_FillGLCaps OpenGL implementation supports 32 vertex samplers and 32 total samplers
fixme:d3d:IWineD3DImpl_FillGLCaps Expected vertex samplers + MAX_TEXTURES(=8) > combined_samplers
fixme:win:EnumDisplayDevicesW ((null),0,0x32f1d8,0x00000000), stub!
fixme:xrandr:X11DRV_XRandR_SetCurrentMode Cannot change screen BPP from 32 to 16
fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x1830c0,0x14ad68): stub
fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x1830c0,0x14ad68): stub

More information about the wine-users mailing list