[Wine] Newbie - missing cursor and unresponsive to input

Thatpenguin wineforum-user at winehq.org
Thu Feb 12 10:41:22 CST 2009

Hello everyone,

          I have just discovered wine and have to try it, 
but I am running into problems that I can't google my way out of.
          I installed wine-1.1.12 using yum on my quad cpu (Nvidia 9500gt, usb qwerty keyboard and mouse) running fedora10 (  and as a test, I decided to use GTA2 (download).

         After the install, I copied mscoree.dll, streamci.dll, dinput.dll,  dinput8.dll  ddrawex.dll from windows XP and put them in system32, installed the latest directx from microsoft.com and then ran winecfg and set those to native as well as a few others I found on a how-to page (the full list attached below). All the boxes under graphics->windows setting are checked.

          I then ran dxdiag. There were a few messages on the console regarding GL and sound, but it claimed that the key and mouse inputs were fine.

           I then downloaded GTA2 and installed it from "Program File"(wine gta2.exe), installshield came up and seemed to work (with a few error mesgs). I ran it and it popped up a window and it looked great, good sound effects and everything. 

           The problem is that this window is responsive only to the first key press, then it is completely unresponsive. The cursor is also missing as soon as I roll it inside the wine window. It is not responsive to mouse clicks. It doesn't matter if I run it in a window or fullscreen (using gta2 manager)

            Is there something I am missing? I'd appreciate any suggestions. Thanks.


More information about the wine-users mailing list