[Wine] Embedded OLE objects problem with Arena Simulation software

deiv wineforum-user at winehq.org
Mon Feb 16 12:12:22 CST 2009

Hi, I'm having problems to install Arena Simulation 10.0, academic edition. I think there is no entry in AppDB about this software. I'm using Wine 1.1.14, which i compiled in a Debian Etch.

The software uses Windows Installer 2.0, and before installing it does a check of required components:
Windows Installer 2.0
MDAC 2.8
JET 4.0 SP3
.NET framework 1.1

and it updates automatically MDAC 2.8 and .NET 1.1 from its installation CD.
Next it continues install apparently fine (it says install was complete), but in the terminal I see quite a lot of errors, which i'll paste below.

After installing, I launch the program and an error msg pops up:

> One or more embedded OLE objects cannot be openened.

The embedded OLE objects are images on a left panel, which are used to create a model of a system. These images appear as a black square(and it won't work). Below I include the errors that appear in the terminal, and also I attach the log of WINEDEBUG.

Then I installed dcom98 via winetricks, and this time the embedded images are loaded, however when I run a model and the analysis report is supposed to be displayed after that, this error pops up:

> Crystal Report Viewer [in title bar]
> Logon Failed.
> Details: DAO Error Code: 0xe31
> Source: DAO.DbEngine

When I installed the program I noticed some OLE errors too, so I tried to install the program again (having dcom98 now), but this time it hangs and it won't launch the installer.  (I didn't install other dlls with winetricks).

I searched in forums/bugs and couldn't find a fix. I'd appreciate some ideas from other more experienced people. I'll do any tests you need me to do. 
By the way, Arena 10.0 can be downloaded from here:


*Errors msgs in the terminal when I run the program:
$ wine start "c:\\Program Files\\Rockwell Software\\Arena 10.0\\Arena.exe"
fixme:exec:SHELL_execute flags ignored: 0x00000100
david at aeris:~$ fixme:ole:CoInitializeSecurity ((nil),-1,(nil),(nil),1,2,(nil),0,(nil)) - stub!
fixme:storage:StgCreateDocfile Storage share mode not implemented.
fixme:storage:StgCreateDocfile Transacted mode not implemented.
err:ole:apartment_getclassobject DllGetClassObject returned error 0x80040111
err:ole:CoGetClassObject no class object {00000315-0000-0000-c000-000000000046} could be created for context 0x3
... [the two above lines are repeated for each OLE object embedded in the file]

fixme:ole:CoCreateInstance no instance created for interface {d3fdb1db-a705-4221-999b-c241666c7426} of class {f2367fc9-deaa-45f4-9c00-45bfcfb94006}, hres is 0x80004002
err:ole:CoGetClassObject class {1f035d99-8eb9-4e21-af30-bb8cf339c2ee} not registered
err:ole:CoGetClassObject no class object {1f035d99-8eb9-4e21-af30-bb8cf339c2ee} could be created for context 0x1
fixme:avifile:AVIFileExit (): stub!

* Debug messages using WINEDEBUG="+ole, +olerelay, +rpc,+storage,+variant"

logfile.zip (http://www.hotlinkfiles.com/files/2295732_cbakc/logfile.zip)

*Errors msgs in the terminal when I install:
installmsgs.txt (http://www.hotlinkfiles.com/files/2295731_c4zre/installmsgs.txt)

More information about the wine-users mailing list