[Wine] Re: Accessing Windows network from application in Wine

RichShark wineforum-user at winehq.org
Tue Feb 17 20:49:20 CST 2009

Thank you for the assistance everyone. I have had a few problems...

vitamin, thank you, I have changed the hosts file accordingly ( after checking with ifconfig:

rich at rich-Evo:/sbin$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:08:02:96:46:7e  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::208:2ff:fe96:467e/64 Scope:Link
          RX packets:82556 errors:0 dropped:0 overruns:0 frame:0
          TX packets:45813 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:116746595 (111.3 MB)  TX bytes:3984282 (3.7 MB)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1574 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1574 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:78700 (76.8 KB)  TX bytes:78700 (76.8 KB)

I assume inet addr: is the one to use? Does this change ever?

Rico, I tried to do what you suggested and got the following error:

rich at rich-Evo:~$ sudo mount -t smbfs "//" /mnt/local
mount: wrong fs type, bad option, bad superblock on //,
       missing codepage or helper program, or other error
       (for several filesystems (e.g. nfs, cifs) you might
       need a /sbin/mount.<type> helper program)
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

James, I assume to give the share its own drive I just have to change some of the above command given by Rico?

On further experimentation I have found that when I find (using Nautilus) the MYOB data file (properties show location as smb://chantelle/myob%20files/) on the Windows XP machine and double click it, it opens in MYOB (in Wine) without a problem. I have tried to 'Make link' to put a 'shortcut' on my desktop (I think) but get an error 'Error while creating link to ... The target doesn't support symbolic links.' I have tried to create a Launcher to run this file but it does not work. How can I do this? I have found that the 'links' to the network are under /home/rich/.gvfs/ where (using Nautilus and selecting 'Show Hidden Files') I can see the other 3 machines on the network (although I cannot seem to access one of them - I think it may be because it is an old laptop with Win 98 and a FAT32 file system). Network properties show locations of the network machines as smb://homenet/.....

I cannot see the .gvs part under the drop down list in MYOB...

I would prefer a Launcher or link to the MYOB file on the desktop that just opens when I double click it.

Thanks for your patience and help, any ideas would be appreciated.

Cheers Richard

More information about the wine-users mailing list