[Wine] programs through wine crashing

tparker tparker at etherstorm.net
Tue Feb 24 14:47:55 CST 2009

I put a new video card in a previously stable system, no other changes.
Now WoW, Ventrilo, and City of Heroes all work for a little while then
crash, sometimes with an error message, sometimes without.

AMD Phenomx4, 5gig RAM
Fedora core 10 x64, installed from disk, fully updated
Wine 1.1.14, installed through yum
New video card: Nvidia geforce 9800gt, 1gig memory
Current video driver: Nvidia 180.29, installed as part of Fedora system

I saw the info on wineappdb about a memory allocation issue in Wine with
systems over 4gig of RAM, but this same computer set up ran perfectly
stable with the old video card (on the mainboard nvidia 6150se, shared
memory) so I was assuming the problem was not that.

I tried putting all in game video settings to minimum and it took longer
but still crashed. When ran from terminal WoW either gives me no error
on crash or gives me this one:

*** glibc detected *** C:\Program Files\World of Warcraft\WoW.exe:
corrupted double-linked list: 0x6902d3a8 *** 
======= Backtrace: ========= 

City of Heroes locks up with no error message, Vent stays open and looks
like it is working, but all sound (send and receive) stops, again with
no error message. Sometimes I can shut down Vent and restart and it will
work again for a few minutes before crashing, sometimes when I try to
restart it tell me Vent is already running and I have to reboot system.
The OS never locks up, just the programs, and things not running through
Wine are fine.

If I run rpm -qa |grep nvidia I get:


I am happy to provide more info, just tell me what and how.


More information about the wine-users mailing list