[Wine] ALSA Sound Regression

TaylorT wineforum-user at winehq.org
Fri Jan 2 14:43:27 CST 2009

I've used wine for several years now, but I've never really gotten involved with development so I'm not sure how or even where this would need to go.

I've found a regression in the latest (as of 1-1-09) git of wine; alsa sound doesn't appear to work. It did work from a version of wine I had cloned from git about a week earlier.  It also works fine in 1.1.11 release.  If I run winecfg and select ALSA as my drivers and push test sound I get a sound.  But any other application that uses sound doesn't work.  OSS causes very odd things, some times the sound will work fine but then it might 'pile up', and then all play at once after about 5 minutes.  I've tried disabling pulseaudio for this as well...but it seems to work fine with it running with 1.1.11.

I've looked in bugzilla and didn't see a bug of this nature open, but I really don't know where to begin on what data to submit.  

I run openSuSE 11.1,  linux (standard suse kernel) on an intel x86_64 quad core processor.

Hopefully I can be of some help if this is a problem, or maybe someone can direct me to what I'm doing wrong if that's the case ;).



More information about the wine-users mailing list