[Wine] Re: internet registering through wine

john.solomon@indysoft.com wineforum-user at winehq.org
Wed Jan 14 09:29:48 CST 2009

No, the installer does not work fine. I have tried wine 1.1.9, 1.1.10 and 1.1.11 and I have tried these wines on Ubuntu 8.04, 8.10 and Fedora 10

There are two parts to the install. 

The first part installs Acr32. Even though it says it failed, it is able to install it. You just have to ignore the fail statements and use the rest of the prompts. The only real issue by the end of this part is that half the time it does not put a menu item. 

the eCabinet part runs for about 15 seconds and then says that the install was interupted. 

These results occur when trying to run the installer from the auto-launch.

I get better results if you run from terminal as root. I end up installing about half of the winetricks before I start.

allfonts, comctl32, comctl32.ocx, controlpad, dotnet20, fm20, fontfix, gdiplus, gecko, jet40, mdac25-27, mfc40 msi2, msscript, riched30, vb6run, vcrun6-2008, wsh56, wsh56vb, ie6. 

You may also have to copy the manifests from the window\winSxS\manifests\*.VC80.CRT and .MFC*

I realize that this is a shotgun, but it seems to help. I also install some wine-doors like opera.

At the end of the install, it may or may not say the install was fine. Files will be transfered, but not all of them. I usually end up copying all then dll's from a good windows install to dir in Ubuntu. 

Sometimes they say to run the daoinstall.exe which installs jet 3.5 and something I can not remember off the top of my head. (per their forum)

You will also need to make user odbc with the ms access driver is installed.

I did a fresh install without installing the wininet trick and was able to connect with the reg server, but from there I was in a loop with the system saying that the version I had expired, but it could not download the new version (5.2 build 4 now available since the 13th) I manually downloaded the file but could not run the .exe.

This is as far as I can get.

I have also attempted to use a program call installrite. From a fresh windows machine, it monitors the install process keeping track of the filed that are moved (added, deleted or modified) and it also keeps track of registry changes. Once done, it compile the changes into an .exe. I can run that in ubuntu, but it does not seem to help. I did this to make sure I got all of the registry modifications.

On occation, when I try to run the program, I will get a blank window to open, but that is all.

More information about the wine-users mailing list