[Wine] Trying to run Spelunky: OpenGL, Mac OS X and Wine

James McKenzie jjmckenzie51 at earthlink.net
Fri Jan 16 21:37:43 CST 2009

magicthread wrote:
> Hi. I'm an OS X user trying to run a freeware GameMaker game with Wine, and I'm running into some trouble. The game is called Spelunky (available here: http://forums.tigsource.com/index.php?topic=4017.0 ). Whenever attempt to run it with Wine, I come across a couple of errors:
> err:dmloader:IDirectMusicLoaderImpl_IDirectMusicLoader_SetObject : could not attach stream to file
> err:wgl:has_opengl  glx_version is 1.2 and GLX_SGIX_fbconfig extension is unsupported. Expect problems.
If you are using Apple's X11 or the X11 supplied by XQuartz, this is 
true.  You might be able to build the version available from Xorg, but 
you will need a great deal of luck and time.  XQuartz states that they 
will  upgrade OpenGL support with XQuartz 2.4.

There is an issue to track issues with this game builder and Wine as well.

Sorry I don't have better news than this.

James McKenzie

More information about the wine-users mailing list