[Wine] I can't install anything in WINE. What am I doing wrong?

nonzer0 wineforum-user at winehq.org
Sat Jan 17 15:06:20 CST 2009

Here is my setup:
Wine version 1.0.1
Ubuntu 8.10 Intrepid Ibex x64

I have tried installing Call of Duty 4, since my friend has a copy and the app db says it works.  However, during the installation, direct x fails to install.  I downloaded direct x 9c and tried to install it, but it fails immediately.  
I have tried different programs over a period of about 9 months, and nothing will work.  Is there a trick to getting applications and games to work in Wine?  It seems like I would need to add windows files (dll's and such) into wine to give it better support for all these applications, but I really don't know.  I have gone through this site and googled around many times, and can't seem to figure out why I have these problems.

For example, when trying to install direct x, the following error is displayed.
"An internal system error occurred.  Please refer to DXError.log and DirectX.log in your windows folder to determine the problem."  

Any help is greatly appreciated.

More information about the wine-users mailing list