[Wine] Re: Using the WINE Program with Sun's Solaris system

Pavel_leon wineforum-user at winehq.org
Mon Jan 19 08:18:21 CST 2009


I've got the same problem, but on OpenSolaris 2008.11.

Yesterday I've enabled "Password Safe" application over wine in Solaris 10 u6 (x86-64) on my home PC and had no problems. Today tried to repeat the procedure on my work notebook on OpenSolaris and it dind't worked  :? .

This is the output:
 |  > uname -a
 | SunOS solplr 5.11 snv_101b i86pc i386 i86pc
 |  > LD_LIBRARY_PATH=/lib
 |  > export LD_LIBRARY_PATH
 |  > /opt/gnu/wine/bin/wine pwsafe.exe
 | err:module:load_builtin_dll failed to load .so lib for builtin L"WS2_32.dll": ld.so.1: wine:  fatal: libnsl.so.1: open failed: No such file or directory
 | err:module:import_dll Loading library WS2_32.dll (which is needed by L"Z:\\z00\\app\\pwsafe\\pwsafe.exe") failed (error c000007a).
 | err:module:LdrInitializeThunk Main exe initialization for L"Z:\\z00\\app\\pwsafe\\pwsafe.exe" failed, status c0000135
 |  > ls -l /lib/libnsl.so.1
 | -rwxr-xr-x   1 root     bin       868592 Nov 13 01:26 /lib/libnsl.so.1
 |  > file /lib/libnsl.so.1
 | /lib/libnsl.so.1:	ELF 32-bit LSB dynamic lib 80386 Version 1, dynamically linked, not stripped, no debugging information available

Installed WINE from sunfreepacks.com, the binary packages for Solaris 10 and Open Solaris are actually different.

I cant't upgrade, 2008.11 (101b) is the last version of OpenSolaris. There are newer versions of SXDE (Solaris Express Developer Edition), but I belive it is not the upgrade path.

What should I do?


More information about the wine-users mailing list