[Wine] Weird problem - can play game only as root

Austin English austinenglish at gmail.com
Sat Jul 11 12:32:52 CDT 2009

On Sat, Jul 11, 2009 at 9:54 AM, Jean-Michel
Bruenn<jean.bruenn at ip-minds.de> wrote:
> Hi,
> i'm trying to run a game within wine using a 32bit chroot. Ago two days it
> was working fine, then i did  something (I don't exactly remember what i did
> as i was doing a lot of stuff, like updating the box etc) and the game is
> not working anymore as "user".
> Game: Rainbow Six Vegas
> Game Version 1.6
> Wine Version 1.1.25 (I also tried 1.1.17 and older versions of wine, same
> thing)
> Starting the Game as user does not work, Starting the game as root works. I
> removed the .wine folder completly and tried again, did not helped. i've
> setup the chroot completly again, did not helped. I can play the game fine
> if i start it as root, just not as user. I think some permissions are wrong
> somewhere but i dont exactly know which and thought you might help me to
> find out. If i start the game, the video is displaying fine, then there's a
> dialog of the game coming "press a key to continue" or similar as soon as i
> press a key - the game is crashing without any message. The last messages
> from WINEDEBUG are:
> fixme:d3d9:Direct3DShaderValidatorCreate9 stub
> fixme:d3d9:Direct3DShaderValidatorCreate9 stub
> fixme:d3d9:Direct3DShaderValidatorCreate9 stub
> fixme:dsound:DllCanUnloadNow (void): stub
> But as i get those as root, too and as it's working as root i dont think
> those are important.

A) Don't run as root.
B) Do you by chance have it on a noexec file system?


More information about the wine-users mailing list