[Wine] More Wine and WOW problems

wowsushi wineforum-user at winehq.org
Sat Jun 13 11:23:50 CDT 2009

I am trying to install wow on ubuntu 9.04x64.
I have installed wine 1.1.23 and have succesfully downloaded and pached wow all the way to the current patch level.
I can start the wow launcher, but when i hit PLAY or start WoW.exe through Wine WOW crashes.
The program never really starts since it has not produced a config.wtf file.

My log from wine looks like this:
Wine WoW.exe -opengl

fixme:advapi:SetSecurityInfo stub
archive Data\enGB\patch-enGB.MPQ opened
archive Data\patch.MPQ opened
archive Data\enGB\patch-enGB-2.MPQ opened
archive Data\patch-2.MPQ opened
archive Data\expansion.MPQ opened
archive Data\lichking.MPQ opened
archive Data\common.MPQ opened
archive Data\common-2.MPQ opened
archive Data\enGB\locale-enGB.MPQ opened
archive Data\enGB\speech-enGB.MPQ opened
archive Data\enGB\expansion-locale-enGB.MPQ opened
archive Data\enGB\lichking-locale-enGB.MPQ opened
archive Data\enGB\expansion-speech-enGB.MPQ opened
archive Data\enGB\lichking-speech-enGB.MPQ opened
fixme:win:EnumDisplayDevicesW ((null),0,0x39edac,0x00000000), stub!

The wow log says:
This application has encountered a critical error:

ERROR #132 (0x85100084) Fatal Exception
Program:	C:\Programmer\World of Warcraft\WoW.exe
Exception:	0xC0000005 (ACCESS_VIOLATION) at 0023:7CD9396A

The instruction at "0x7CD9396A" referenced memory at "0x00000018".
The memory could not be "read".

Can anyone tell me what the problem seems to be, and how to fix it?

More information about the wine-users mailing list