[Wine] Test network under wine

Oliver aka v1k1ng0 ofabelo at gmail.com
Tue Mar 10 17:13:39 CDT 2009

I reply between lines ...

2009/3/10 A. Tres Finocchiaro <tres.finocchiaro at gmail.com>

> Oliver,
> I tried launching FML Live and it opens perfectly.  I've found a few
> ways to open it.  First is to download the "setup.exe" from the
> website.  This worked first try and began downloading the game.  The
> download took about 10 minutes to complete. (17.6M)
> Second was to download and extract "fml_full_win32.zip", which has its
> own "fml_launcher.exe". The launcher seems to do the same thing as the
> "setup.exe" by connecting to the Internet and downloading the latest
> version.
> Third was running "fml.exe" in the "data/bin/app_2959/" of the
> extracted archive.  My wine install is not vanilla so results may
> vary, however, I noticed that the launcher -- as you stated -- isn't
> verbose as to what it is doing.  In fact, the launcher doesn't have
> ANY output to the wine console.  On the contrary, the "fml.exe" was
> verbose!  Here's my output:
> > tfino at crap:~$ wine '/home/tfino/Desktop/fml/Football Manager
> Live/data/bin/app_2959/fml.exe'
> > fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
> > fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x13dd78,0x13e7d8): stub
> > err:winebrowser:get_url_from_dde Unabled to retrieve URL from string
> L"\""
> > err:winebrowser:wmain Usage: winebrowser URL

hey! It works for me too, with fml.exe, downloading the full client (under
my Debian Sid). My output is the next:

fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x1321c8,0x132960): stub

> The "get_url" message in the above console log seems to be in regards
> to the "Sign Up" button, which appears to be broken.  It depresses,
> but doesn't do anything else.  I did not sign up for an account so I
> cannot confirm functionality.  Since the client updates itself, I will
> rule out connection issues on my platform.
> Note also that when launching from the "fml.exe" it takes a few
> minutes to load and appears unresponsive at first.  This seems normal.
>  What version of the Ubuntu cd did you try?  What type of Internet
> connection do you have?  Please post your success with this method.

Ubuntu 8.10 x86. I have a dsl router, a cisco router (877W), and connected
to the router, an access point, it offers dhcp to my client. I tried direct
connect using cable, from my laptop to the dsl router, and it doesn't work
(using fml_launcher.exe).
I will try ubunt 8.10 again with wine 1.1.12, I will comment with it later.

> Here's a screenshot:
> http://img19.imageshack.us/img19/2936/screenshotf.png
> I'm on Ubuntu 8.10 x86-64.  Wine 1.1.12, Kernel 2.6.27-11-generic.
> This application actually works amazingly in Wine for me.  I hope my
> test helps you out Oliver.  If this information is helpful to someone,
> please copy it to the AppDB page for FML.
Thank you very much Tres.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.winehq.org/pipermail/wine-users/attachments/20090310/f39c4195/attachment.htm>

More information about the wine-users mailing list