[Wine] OSX 10.5 - XQuartz 2.3.3 - GLX issue

mastorak wineforum-user at winehq.org
Wed Mar 11 06:24:05 CDT 2009

Hi all, 

A couple of days ago I decided to give wine on a mac a try caused I got bored of dual booting my mac. I ve been A linux wine user for years and I had some pretty good results with it. I figured that i would have the same results on a mac but i guess I was wrong.

I got my version (wine-devel packet  wine 1.1.16) from macports. Got winetricks as well.
Everything were setup fine and everything was working fine. I got some windows programs running as well just for testing. So far so good.

I also installed XQuartz version 

When I got to the part to make a game run though that was a different deal. 
I decided to start with Platinum game so i got my half life retail copy out to give it a try.
It installed fine no problems launched from steam as well. But then the log gave me a

rr:wgl:has_opengl  glx_version is 1.2 and GLX_SGIX_fbconfig extension is unsupported. Expect problems. 

I suspected it had something to do with X11 implementation so i checked over at xquartz site and found this ticket discussion

JeremyHu is providing a beta version of 2.3.3 that supposedly solves the issue as the ticket is set to resolved

> http://static.macosforge.org/xquartz/downloads/X11-2.3.3_beta1.dmg

i tried it and I can report that it is not giving the same error code however it is not working for me eitherhttp://static.macosforge.org/xquartz/downloads/X11-2.3.3_beta1.dmg.
Th game launches but the x11 refuses to render the game on the screen i can hear sound though. I move windowz over the screen in order to make it render something and the Valve logo is showing it stays for a few seconds and then crashes.

Bottom line it is not working. Has anyone have better luck than me with this.[/code]

More information about the wine-users mailing list