[Wine] IPX and AMD64 not mixing?

Gert van den Berg wine-users at mohag.net
Mon Mar 30 23:07:53 CDT 2009

On Tue, Mar 31, 2009 at 5:52 AM, Sephiroth <wineforum-user at winehq.org> wrote:
> When trying that, I get the same error described above.
> Code:
> ~/.wine/drive_c/Games/Sierra/LOMSE$ su - root wine ./lomse.exe
> Password:
> /usr/bin/wine: /usr/bin/wine: cannot execute binary file
You need to use 'su -' on its own or use the -c parameter if you want
to run a command (with -c you might need to enclose the command in

> Since "-" and "-l" are the same, I tried "-l" also with identical results.  You are right though, 1024+ are usable by normal users.  I cannot understand for the life of me why they even bothered putting in IPX support if it's broken and useless.  I am really aggaravated at the insane amount of trouble I am having with such a reliable protocol in Linux.  I probably have around 30 games that rely solely on IPX for LAN games that will be unplayable if this can't be fixed.  I love Linux, but with the alpha-state of the ath5k module being included in new kernels and this broken IPX crap, I am beginning to lean towards XP again.  At least I can dual-boot 32bit and 64bit XP and use my games.
You might want to give Solaris / OpenSolaris / a BSD a shot as well,
they may / may not have similar limitations concerning non-root IPX
use... (Solaris has RBAC which should alllow capabilities to be
assigned more finely... With the trusted extensions you can assign
permissions to just about anything...)

To try figuring out the relevant POSIX capability on Linux might work as well...

The likely candidates seem to be:

http://www.gentoo.org/proj/en/hardened/capabilities.xml has a full list...

An introduction to POSIX capabilities:

setfcaps seem to be the relevant command, I presume that it needs to
be run on the wine executable... No idea in which package you can find


More information about the wine-users mailing list