[Wine] alsa not available in winecfg under karmic?

Susan Cragin susancragin at earthlink.net
Tue May 12 08:06:46 CDT 2009

Well, I re-installed Karmic successfully, with no modifications, special kernels, drivers, etc.
First I tried the wine from the repository, which is 1.0.1. Winecfg showed all the expected drivers and mixers, including alsa, eSound, and jack. I got the alsa-driver to work for me with the same problem I'd had before, that it freezes up after a certain amount of time when I do training in DNS. The OSS driver worked without freezing, but the sound quality wasn't as good. Sound on OSS using a USB device was acceptable. 

Then I uninstalled the distro package and built wine from git. (The only dev package that isn't available right now is libcups2-dev.)
Then I ran winecfg. 
The OSS driver was the ONLY one that showed up. No alsa, no eSound, no Jack.
I have a screenshot, if anyone is interested. 

Here is a list of the dev packages that you want, if you want to build. Certain packages are not mentioned below because they are installed automatically by others.

bison flex compiz-dev libfreetype6-dev libxft2-dev libxi-dev libxxf86vm-dev libglu1-mesa-dev libhal-dev libgnutls-dev libncursesw5-dev libsane-dev liblcms1-dev libcapi20-dev 


More information about the wine-users mailing list