[Wine] ulimit -n ignored/ Max files reached

Darragh Bailey felix at compsoc.nuigalway.ie
Fri May 15 09:16:31 CDT 2009

On Fri, May 15, 2009 at 05:34:53AM -0500, houkouonchi wrote:
> Ok, so doing:
> ulimit -n <value>
> then running wine right after that won't work? I also tried putting it in my .bashrc which didn't help either. 
> I in the past already tried editing /etc/security/limits.conf but it doesn't seem to be making a difference. Even if I run env-update any new shells or anything like that would just use my old limit of 1024. I never had issues like this on rtorrent when I just ran ulimit -n <value> before starting it up but I am guessing wine works differently.
> Do you know how I can get the values in /etc/security/limits.conf o take affect without rebooting. I can't reboot this machine.
> Thanks for the info!

You will have to logout completely and restart your session in order for
it to take effect. 

To test I would try adding the following to /etc/security/limits.conf
<username>	hard	nofile	8192 

Then after restarting your login session, try the following command
# ulimit -Hn

Worked perfectly fine here for me. 


"Nothing is foolproof to a sufficiently talented fool."

More information about the wine-users mailing list