[Wine] configure fails to see deps when installing on rhel 64bit

archie1983 wineforum-user at winehq.org
Wed May 20 03:13:41 CDT 2009

I'm trying to install the latest wine (wine-1.1.21) from source tar-ball onto a RedHat 5 64-bit server. When I first started, it warned me about a lot of missing libraries (mostly all sorts of 32-bit development files but also some applications like icotool and fontforge). Now I've managed to resolve most of them by running "./configure --enable-maintainer-mode" and then installing the missing dependencies one by one. So I've gotten to the point when there's only two dependencies left:

configure: libgnutls 32-bit development files not found, no schannel support.
configure: libcapi20 32-bit development files not found, ISDN won't be supported.

I have installed both "isdn4k-utils-devel.i386" and "isdn4k-utils-devel.x86_64" which should provide libcapi20 development files and I have installed both "gnutls-devel.i386" and "gnutls-devel.x86_64". I have tried to go through wine configure with only 32- bit versions of these development packages installed and I also have tried it with only 64-bit packages installed. The result unfortunately is exactly the same-- these two packages are invisible to wine configure. 

All the other configure errors disappeared when I installed the respective development package, but not these two. So I suspect that wine just looks for the header files in the wrong place, however altering that, is beyond me. 

Also interesting point is that it was also missing hal-devel at the beginning and the problem didn't go away when I installed "hal-devel.i386". It only stopped complaining about hal-devel when I also installed "hal-devel.x86_64" and had them both on.

Please help if you can!

More information about the wine-users mailing list