[Wine] Half-Life starts fine with sound, but freeze on start game

James Huk huk256 at gmail.com
Sun May 24 05:40:22 CDT 2009

2009/5/24 The-DarkLord <wineforum-user at winehq.org>

> Hello again :)
> I have installed Half-Life through wine. As reported in appdb it works
> without trouble.
> When I start it with sound (alsa), it freezes during intro logo. Sound goes
> on but nothing happens.
> When I start it using oss and oss IS ALREADY USED, i have no sound but game
> dont freeze during intro logo.
> Starting the game with --console and alsa, there is no intro logo and it
> starts with sound, i can use the menu and stuff. So thats my choice :)
> Now my problem:
> Wenn i change the grafic settings to opengl and lets say 1024x768 as
> resolution, nothing happens... i can remember in windows it got reload with
> new resolution. When i quit game and start again, the menu says i run the
> settings i have chosen but it seems still 640x480.
> When i try to start a game it opens that loading logo and try to pull up
> that picture (as it does in windows) but then it crashes.
> Edit: I just tested it to see what error-msg is the output of wine but it
> freezes and sound of game starts (but it dont pull up that loading screen).
> Any suggestions?
> Best regards Dark
> For sound:
Console output please ;]

If you don't know what I'm talking about simply start terminal, cd to
Half-Life dir and run it with:

wine exe (or where exe is the exe file name of Half-life)

Now when hl crash, terminal will be full of... something ;] - paste it here.

For graphics:

If I remember correctly – I had a problem similar to yours – I found out
later that every time I opened some menu, hl created new window for it and I
had to switch between those windows to get everything working... try alt+tab
while you are in video options and see if there are any confirmation boxes
(“Are you sure you want to set this graphioc mode?”) there that are not
visible (behind current window) – I don't know if this is still a problem.

Anyway if I remember correctly – starting HL in virtual desktop fixed this
(you can always set everything you want and then restart game without
virtual desktop)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.winehq.org/pipermail/wine-users/attachments/20090524/26b76778/attachment.htm>

More information about the wine-users mailing list