[Wine] DarWine & OpenGL

ryan woodsmall rwoodsmall at mac.com
Wed May 27 18:32:46 CDT 2009

The DISPLAY changing is not a bug.  When Xquartz restarts (or starts  
as a different user), a new socket is created in /tmp/launch-XXXX/:0,  
where XXXX is random.

rbwmb:~ ryan$ echo $DISPLAY

Are you setting DISPLAY manually somewhere?  If you are, don't.   
launchd should take care of all that for you.

Regarding the other error: roll your own, compile Wine from source and  
circumvent the Darwine setup.  Not nearly as nice (no winehelper.app),  
but you'll get more help from the forums.

   ryan woodsmall
     rwoodsmall at mac.com

"Be well, do good work, and keep in touch." - Garrison Keillor

On May 27, 2009, at 2:56 AM, pinchies wrote:

> *reposting my current unsolved problems:
> I think that there is a bug in Xquartz or winehelper somewhere, as  
> with the latest build sometimes the $Display variable  
> changes randomly, resulting in wine complaining of errors that it  
> cant find the screen. Wine used to crash occasionally, but it would  
> never give this error, and would normally reconnect back to X11  
> easily.
> "Application tried to create a window, but no driver could be loaded.
> Make sure that your X server is running and that $DISPLAY is set  
> correctly."
> I can bypass this error by using "$ var" and putting the $display  
> manually into winehelper.
> ***I also have one final problem - and I have checked the FAQ. ***
> Some programs complain that their resources are missing, and seem to  
> be looking in "winehelper.app/contents/resources/" instead.
> This error is mentioned here:
> http://forum.winehq.org/viewtopic.php?t=4614
> Is there a solution anyone knows of?

More information about the wine-users mailing list