[Wine] sims 3 'direct rendering' problems

pedepy wineforum-user at winehq.org
Fri Nov 27 01:41:57 CST 2009

although using directx as been a generally awful experience under wine, it's especially bad with the sims 3.

the game installs, and 'seems' to run just fine .. problem is, it runs at about 1 frame per second. i get a bunch of 'get x input' fixme messages at about 1fps too, although i dont think theyre related (i get em a bit earlier in the startup process and the go by quickly).

I *do* get some opengl, wined3d fixme's though, here they are:


fixme:d3d:debug_d3dformat Unrecognized 1414745673 (as fourcc: INST) WINED3DFORMAT!                                                                     
fixme:d3d:getFormatDescEntry Can't find format unrecognized(1414745673) in the format lookup table                                                     
fixme:d3d:IWineD3DDeviceImpl_CreateQuery (0x175278) Event query: Unimplemented, but pretending to be supported                                         
fixme:thread:SetThreadIdealProcessor (0x17c): stub                                                                                                     
fixme:d3d_shader:vertexshader_set_function The difference between the minimum and maximum relative offset is > 127                                     
fixme:d3d_shader:vertexshader_set_function Which this OpenGL implementation does not support. Try using GLSL                                           
fixme:d3d_shader:vertexshader_set_function Min: 0, Max: 132        

... im running this under fedore 12, 32 bits. using the open source radeon drivers. perhaps interestingly, i also attempted the same under 64 bit archlinux, with bin32 wine - i had the very same behavior, except textures were also rotated and twited. i used to think they were related bugs but in fedora the image appears intact - but it is still horribly slow.

if it means anything, running simcity 4 in 'hardware' rendering mode is also quite slow, although not nearly as much. ive tried using built-in and native versions of d3d dll's ... ive tried running full screen vs emulated desktop ... ive tried *ALL* of the directX registery entry tricks .. to no avail.

id realyl like to not have to install windows to play the sims 3 .... searching the opengl string errors in google only gives me some cryptic pastebin entry from asia ... 

so please help ! ......................

More information about the wine-users mailing list