[Wine] Bioshock 2 - DLL problem during installation

tgeer43 wineforum-user at winehq.org
Fri Apr 9 12:29:29 CDT 2010

Hello folks,

First post here - hoping for some help.

I'd really like to give BioShock 2 a go under Wine/Ubuntu 9.10 64-bit but I'm getting stumped early on. After selecting the installation language the InstallShield Wizard loads quickly then exits with the following error dialog:

Unhandled Exception
Error Number: 0x80040703
Description: Failed to find DLL function: Shell32.IsUserAnAdmin

Setup will now exit.

I did some research and it seems that the function call: IsUserAnAdmin in Shell32.dll is not present in all versions of the DLL. The details were vague but I gathered that the versions included with XP and Vista were ok. Tried configuring Wine to run the installer under both XP and Vista profiles but no luck. I then tried overriding the libraries to run a native version of shell32.dll. Actually I tried several different versions but none of them will even allow the installer to run.

So here I sit scratching my, er.... head.

Any help would be greatly appreciated.


More information about the wine-users mailing list