[Wine] Heroes of Might and Magic 2 won't start

Zovits wineforum-user at winehq.org
Wed Apr 14 23:33:13 CDT 2010

I just tried HOMM2 with Wine. I run Ubuntu 9.04 (Jaunty) and have Wine 1.1.41.
First I started Autorun.exe in the _AUTORUN folder. The Wine "desktop" apperared, an so did the frame of the application's window. The sound worked perfectly, even when mousing over one of the "icons". But there was no picture. The window's content was "copied" from the desktop, and stayed the same regardless of any action. (I think this might be an issue with window refreshing, and/or drawing.)
Not giving up, I fiddled with the graphics settings, with no notable result. After turning off the "desktop", the window copied it's contents from the window beneath it (Nautilus in this case).
Then I started setup.exe (the one in the CD's root). It did not produce any visible results. Using the system monitor I could see two wine... processes starting and ending promptly.
After this I tried _SETUP/setup.exe. This version would start up normally, showing the InstallShield tool's first few panels. However, after giving the installation directory, I got an error stating: "General file transfer error.Please check your target location and try again. Error number:-1." The target location was Wine's Program Files directory, and the next time Wine's C: root. Both gave the same error message.
Then I gave HEROES2/heroes2w.exe a try. It worked just right, except it did not "see" the CD in the drive. (Well, there was no CD, since the original was rendered inoperational a long time ago, and only an iso image remained, that was mounted at the time) And no CD means no game either.
For the last try, I started /HEROES2/editor2w.exe. It started, it worked perfectly, until I opened and messed around (i.e. filled in the textboxes) at the specs menu. Then the mouse pointer seemed to "shift" the pixels a bit after passing over them. And when I moved the pointer to the bottom of the screen, I got this error: "DirectDraw error: 'DDERR_INVALIDRECT    ' File: 'D:heroes2/Editor/wingraph.cpp' Line:265"

I also tried running autorun.exe (the one with the frame and the copied visuals) from terminal and capturing the outputs.
This was the result:
err:alsa:ALSA_CheckSetVolume Could not find 'PCM Playback Volume' element
err:alsa:ALSA_CheckSetVolume Could not find 'PCM Playback Volume' element
fixme:mixer:ALSA_MixerInit No master control found on ATI IXP Modem, disabling mixer
fixme:msvideo:DrawDibRealize (0x1, 0x2b4, 0), stub
ALSA lib pcm.c:7228:(snd_pcm_recover) underrun occured
err:mmio:MMIO_ParseExtA No . in szFileName: "\x07"
err:wave:wodPlayer_WriteMaxFrags Error in writing wavehdr. Reason: ErQforrás átmenetileg nem érhetQ el
{This last sentence (the reason) means: The resource is temporarily unavailable}
{This exact line (err:wave...) repeats 10155 times}
ALSA lib pcm.c:7228:(snd_pcm_recover) underrun occured
ALSA lib pcm.c:7228:(snd_pcm_recover) underrun occured
err:mmio:MMIO_ParseExtA No . in szFileName: "\x07"

Any help would be appreciated.

More information about the wine-users mailing list