[Wine] Mac OS X From Source

CDeLorme wineforum-user at winehq.org
Fri Apr 30 21:03:46 CDT 2010


I really would have prefered a contribution as my first post instead of a question, but having spent the better part of the last three days scouring the web, forums, and websites I am left with this as my final option.

I cannot get the latest Wine to compile on my Mac OS X 10.6.3 Snow Leopard with the dependancies I want to have installed.  My system is a MacBook Pro /w 4GB RAM 667 Mhz, and a 2.2 Ghz Intel Core 2 Duo Processor, I do other development on my system so I had already installed XCode.

I have set the following flags per the instructions pages (I have read every page, many times as well for help):

export CFLAGS="-arch i386 -m32"
export CPPFLAGS="-I/usr/X11/include"
export LDFLAGS="-L/usr/X11/lib"

I intend to test many different applications with Wine, it is an awesome (potential) solution to having a VM eat resources and fail to deliver.  Before you ask, I have already attempted the macports install, it installed but with similar dependancy issues.  After that I also tried WineBottler, but debugging anything in that is like pulling teeth without anesthetics.

It's more beneficial to me to learn through mistakes and end up with a better understanding and being able to debug problems as they come up, than to use a pre-built or scripted solution.  That said I downloaded the lated git of Wine, and ran the configure the first time, I looked up the dependancies and downloaded the ones I wanted (in particular libpng, libjpeg, and libgnutls).

I installed all three, libpng worked on the first go and seems to be just fine.  However the configure still can't find libtiff, libjpeg, and libgnutls.

This is what I get at the end of my verbose configure, and without the "WARNING" it also lists libtiff and libgnutls (among a few others I am not concerned with).

configure:16243: WARNING: libjpeg 32-bit development files not found, JPEG won't be supported.

At the top of the config I have these, and if x86_64 indicates 64 bit compile then apparently I am not setting something right because I am pretty sure 64 bit Wine won't work with most of the applications I want to run unless I misunderstood the 64 bit page.

checking build system type... x86_64-apple-darwin10.3.0
checking host system type... x86_64-apple-darwin10.3.0

I also opened the config.log file and located these two lines, which lead me to believe it found the libraries but can't use em because they are the wrong architexture (Probably 64 bit as I am on Snow Leopard):

ld: warning: in /usr/local/lib/libjpeg.dylib, file was built for unsupported file format which is not the architecture being linked (i386)

ld: warning: in /usr/local/lib/libtiff.dylib, file was built for unsupported file format which is not the architecture being linked (i386)

After that I googled for several hours to try and find out to force compile into 32 bit more, and found minor scraps of information similar to the flags (environment variables) for the wine install.  I tried several configurations of those flags, and finally I managed to change the configure log for libjpeg from x86_64-apple-darwin10.3.0 to i386-apple-darwin10.3.0, and compiled/installed successfully, I think!

The problem is I have no idea how to check the version/architexture of a lib file, and yeah google wasn't very helpful there either.  So I ran the wine configure again, and to my dismay still throwing up its hands at a missing supported libjpeg architexture.

I have tried searching the forums for similar issues to my own, but I haven't found anything directly related.  If anyone could lend me some support it would be greatly appreciated.

Also here is a complete list of the files not found:

configure: libhal/libdbus 32-bit development files not found, no dynamic device support.
configure: libgnutls 32-bit development files not found, no schannel support.
configure: libsane 32-bit development files not found, scanners won't be supported.
configure: libv4l 32-bit development files not found.
configure: libgphoto2 32-bit development files not found, digital cameras won't be supported.
configure: liblcms 32-bit development files not found, Color Management won't be supported.
configure: libcapi20 32-bit development files not found, ISDN won't be supported.
configure: libgsm 32-bit development files not found, gsm 06.10 codec won't be supported.
configure: libtiff 32-bit development files not found, TIFF won't be supported.

More information about the wine-users mailing list