[Wine] Getting EPROM programmer software to work under Wine

Mr Ian Primus ian_primus at yahoo.com
Wed Aug 11 08:48:47 CDT 2010

I have some software for an EPROM programmer that's intended to run under Windows. Of course, I would much rather it work on Wine...

The software in question is available here:

It installs fine, but when I run it, the software loads it's UI, and then throws up a message box that says simply "EPrivilege". When you click OK, the program closes.

The program, tested on my PC at work running XP, does work under Windows. Under Windows, it displays a message that it can't communicate with the programmer (since it's not attached), but all the menus work. Under Wine, it never even displays that message - it seems to die as soon as it tries to communicate.

I have a feeling this has to have something to do with the access to the parallel port. I've read the various documentation online, and I've tried adding the requisite keys to the registry for direct parallel port I/O. I have also used winecfg to set Wine to run as Windows 98 (since from what I've read, only 9x programs can do direct parallel I/O without a driver). I've set the permissions on /dev/parport0 so I should be able to access it. I've also tried running Wine as root.

I still get exactly the same message.

I have also tried setting the WINEDEBUG environment variable as documented by the manpage, but I get no debugging messages on the terminal.

I'm really stumped here. If it matters, I'm running Debian 5.0, with Wine installed via apt.

Any help in getting this to function would be greatly appreciated. I don't currently have a PC at home running Windows, and I don't want to start now :)

Thanks in advance!


More information about the wine-users mailing list