[Wine] No MIDI devices in wine [solved]

Klaus-Peter Schrage kpschrage at gmx.de
Sat Jan 2 08:06:18 CST 2010

Am 02.01.2010 14:28, schrieb Klaus-Peter Schrage:
> Am 01.01.2010 22:16, schrieb vitamin:
>> Klaus-Peter Schrage wrote:
>>> In winecfg's sound tab, there is no ALSA entry at all, perhaps that
>>> is part of the problem (I get sound in Wine through Pulseaudio).
>> Pulseaudio knows nothing about MIDI and can't work with it. In Wine
>> only ALSA backend driver supports MIDI.
>> Klaus-Peter Schrage wrote:
>>> And using a soft synth doesn't help, because I want to address the
>>> MIDI hardware of my soundcard.
>> You have to properly set everything up, including on the ALSA side
>> too.
> ALSA seems to be set up properly; my soundcard (DMX6Fire) is well
> supported for a long time now, and everthing works for me as expected.
> But I can't get an ALSA entry in winecfg (and so there is no MIDI);
> sound in wine works via pulseaudio, and if I disable pa, the only sound
> driver available in wine is jack.
> Klaus
I found that the Fedora packagers don't include ALSA support by default 
(they love Pulseaudio). Installing the additional wine-alsa package from 
the Fedora repository solved the problem, and now my Tonelab editor 
works as expected.

More information about the wine-users mailing list