[Wine] 32-bit libmpg123 on Gentoo

John Drescher drescherjm at gmail.com
Fri Jan 15 08:27:16 CST 2010

On Fri, Jan 15, 2010 at 9:04 AM, dimesio <wineforum-user at winehq.org> wrote:
> Das Letzte Einhorn wrote:
>> I noticed something strange today when testing TES3 : Morrowind. I use 64 bit Gentoo.
>> Despite having the libmpg123 files installed as part of my x86-soundlibs emulation package : http://bugs.gentoo.org/show_bug.cgi?id=283912 , mp3 playback still does not work. I ran a configure command on my wine source and I still get this message : configure: libmpg123 32-bit development files not found (or too old), mp3 codec won't be supported.
>> The x86 libmpg123 files I have are :
>> /usr/lib32/libmpg123.so.0.20.3
>> /usr/lib32/libmpg123.so.0
>> /usr/lib32/libmpg123.so
>> /usr/lib32/mpg123/output_pulse.so
>> /usr/lib32/mpg123/output_portaudio.so
>> /usr/lib32/mpg123/output_oss.so
>> /usr/lib32/mpg123/output_jack.so
>> /usr/lib32/mpg123/output_dummy.so
>> /usr/lib32/mpg123/output_alsa.so
>> Is there anything missing for this to work?
> As the message says, you're missing the development files. Two files I see on my system (openSUSE) from the libmpg123-devel package that you don't have are:
> /usr/include/mpg123.h
> /usr/lib/libmpg123.la

I have both of these files on my 64 bit gentoo system however I am
using the my own fork of multilib overlay and not the official 32 bit
emul libs.

Here is the wiki from the original sources:


More information about the wine-users mailing list