[Wine] Problem With Wine and .MSI program

Sanford wineforum-user at winehq.org
Sun Jul 25 00:40:38 CDT 2010

Hi folks.  I am new to the forums and have only minimal experience with wine.  I am trying to convert completely to Ubuntu but have been unable to get a few programs to work.  One is a program for downloading audio books from my local library.  It is an .msi file.  I tried installing it using both the "wine msiexec /i program.msi" command and the "wine start program.msi" command as described in the WineWiki.  (Yes i ran them from the directory that the program I want to run is in.)  I get the following error message:    

desktop:~/Desktop$ wine msiexec /i ODMediaConsoleSetup.msi
fixme:advapi:LookupAccountNameW (null) L"sanford" (nil) 0x32f390 (nil) 0x32f394 0x32f388 - stub
fixme:advapi:LookupAccountNameW (null) L"sanford" 0x133e20 0x32f390 0x167f08 0x32f394 0x32f388 - stub
fixme:msi:MsiGetMode unimplemented run mode: 4
err:msi:ITERATE_Actions Execution halted, action L"VSDCA_VsdLaunchConditions" returned 1603

I have tried a few things.  For example, as suggested in another post with a similar error message about a different program, I opened "winefile" from a command prompt and navigated to the file i want to install and double clicked it.  Nothing happened at all.  

The same person suggested the following advice.   "You need rid from msiexec in your wine installation. Run winecfg, go to Libraries tab, remove msi(native) and msiexec. After it run "wine start EuroScopeSetup31.msi". For me it's works."  I went to wine libraries and there were none to remove.  Could that be the problem?  

I am using Ubuntu 10.04 and it has wine 1.2.  Any help would be much appreciated.  Thanks in advance.  Sanford

More information about the wine-users mailing list