[Wine] Can't start Wine after suspend on Laptop

James Mckenzie jjmckenzie51 at earthlink.net
Mon Jun 7 12:43:22 CDT 2010

sforces <wineforum-user at winehq.org> wrote at Jun 7, 2010 6:24 AM (MST)
>walt wrote:
>> On 06/05/2010 07:51 AM, sforces wrote:
>> > Currently running Wine 1.2-rc2 on Ubuntu 10.04 x64 on a Lenovo ThinkPad x61. After doing a suspend, I can't run Wine. The app I normally run with Wine is Lotus Notes. But I've tried something as simple as going in to the wine config. I tried doing a wineserver -k but that doesn't help either. Only thing I found to work is a full reboot.
>> > 
>> > 
>> Is wine the only app that doesn't work after suspend?  On other lists I've seen
>> many complaints about various other things that act the same way after suspend.
>> I can't be certain, but I believe the kernel is involved in the bug.
>> After waking up, does ps show anything running that may be related to wine, e.g
>> some wine process that isn't responding.  If yes, try killing that process and
>> then try running wine again.
>> Any messages that show on the command line when you start wine that way?
>Seems to be just Wine. Everything else appears to be running fine and responds to application restarts. I've even tried exiting from all Wine apps before doing a suspend and then running a wineserver -k on resume before running any apps. But that doesn't appear to help. When wineserver -k hadn't helped, I tried looking for wine processes but didn't see any running. Perhaps I'm missing one -- what should I be looking for?
First: Please bottom post.  Your replies are sent to a mailing list.

Second:  After you suspend your laptop and bring it back to life, open a terminal session and type in:


ps -ef | grep wine


Post the results, including the command, back here.  Based upon what you have written, it appears that the Wine processes are not surviving a suspend.

James McKenzie

More information about the wine-users mailing list