[Wine] Problem running any games with Steam

ahakala wineforum-user at winehq.org
Mon Jun 21 00:07:08 CDT 2010

When ever I try to run FEAR 2 or Half-Life in Steam the "Preparing to launch" window comes up and then disappears. I assume every game I have will do this same thing, but it takes way to long to install anything in Steam.

Both games produce the following output in the terminal:


err:ole:CoGetClassObject class {9a5ea990-3034-4d6f-9128-01f3c61022bc} not registered
err:ole:CoGetClassObject no class object {9a5ea990-3034-4d6f-9128-01f3c61022bc} could be created for context 0x1
err:seh:raise_exception Unhandled exception code c0000005 flags 0 addr 0x7edf8574
err:ole:RevokeDragDrop invalid hwnd (nil)
err:ole:RevokeDragDrop invalid hwnd 0x30114

I am using Wine v1.1.43, I have the most up to date Nvidia drivers, and have tried reinstalling them twice. I have also tried reinstalling Wine, Steam, FEAR 2 and Half-Life, but I still get the exact same errors.

Thank you in advance for any help.

System Specs:
OS: Gentoo(amd64)
CPU: AMD64 X2 6000+
Video Card: Nvidia 8800GT 512MB

More information about the wine-users mailing list